<!DOCTYPE html>
<html lang="en_US">
<head>
    <title>Home or away, prospects winning at love | MiLB.com </title>

    <!-- meta meta tag -->
    <meta charset="utf-8"/>
    <meta http-equiv="X-UA-Compatible" content="IE=Edge" />
    <meta http-equiv="content-type" content="text/html; charset=UTF-8"/>
    <meta http-equiv="Cache-Control" content="no-cache"/>
    <meta http-equiv="Pragma" content="no-cache"/>
    <meta http-equiv="Expires" content="-1"/>
    <meta http-equiv="content-language" content="en">
    <meta name="keywords" content="Weston Wilson, Andrew Schwaab, Tommy Eveld, Carolina Mudcats, Milwaukee Brewers, New York Yankees, Tampa Yankees, Arizona Diamondbacks, Kane County Cougars, proposal, marriage, Valentine&#x27;s Day"/>
    <meta name="page_name" content="milb" />
    
    <meta name="page_section" content="News" />
    
    
    
    
    <meta name="twitter:card" value="summary_large_image">
    
    <meta property="og:title" content="Home or away, prospects winning at love" />
    <meta name="twitter:title" content="Home or away, prospects winning at love">
    <meta itemprop="name" content="Home or away, prospects winning at love MiLB.com"/>
    
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
    <meta name="env" content="production" />
    
    <meta property="og:site_name" content="MiLB.com" />
    <meta property="og:type" content="website" />
    
    <meta property="fb:app_id" content="222050774479731" />
    
    <meta name="twitter:site" value="@milb">
    <meta name="twitter:url" content="https://www.milb.com/milb/news/home-or-away-prospects-winning-at-love/c-266053500">
    <meta name="twitter:description" content="Being in a romantic relationship while playing the Minor Leagues is difficult, but for Weston Wilson, Andrew Schwaab and Tommy Eveld -- and their respective partners -- it&#x27;s just life.">
    
    <meta property="og:image" content="https://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/640x360/cut.jpg" />
    <meta itemprop="image" content="https://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/640x360/cut.jpg" />
    <meta name="twitter:image" content="https://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/640x360/cut.jpg">
    
    <link rel="canonical" href="https://www.milb.com/milb/news/home-or-away-prospects-winning-at-love/c-266053500" />
    <meta property="og:url" content="https://www.milb.com/milb/news/home-or-away-prospects-winning-at-love/c-266053500" />
    
    <meta name="description" content="Being in a romantic relationship while playing the Minor Leagues is difficult, but for Weston Wilson, Andrew Schwaab and Tommy Eveld -- and their respective partners -- it&#x27;s just life." />
    <meta property="og:description" content="Being in a romantic relationship while playing the Minor Leagues is difficult, but for Weston Wilson, Andrew Schwaab and Tommy Eveld -- and their respective partners -- it&#x27;s just life." />
    <meta property="description" content="Being in a romantic relationship while playing the Minor Leagues is difficult, but for Weston Wilson, Andrew Schwaab and Tommy Eveld -- and their respective partners -- it&#x27;s just life." />
    
    <meta name="build" content="true" />
    
    <meta name="server_url" content="https://www.milb.com" />
    <meta name="service_url" content="" />
    <meta name="suggest_url" content="" />
    <meta name="uistatic_url" content="//prod-aws.milbstatic.com" />
    <meta name="context-url-prefix" content="/milb" />
    <meta name="bamcontent_client_url" content="https://s3.amazonaws.com" />
    <meta name="control_plane_url" content="" />
    <meta name="control_plane_client_token" content="" />
    <meta name="recon_rest" content="https://www.milb.com" />
    <meta name="recon_ws" content="wss://www.milb.com" />
    <meta name="msapplication-config" content="none"/>
    <meta name="locale" content="en" />
    
    <meta name="flipTime" content="11:00" />
    <meta name="flipTimeZoneOffset" content="+00:00" />
    <meta name="serverTime" content="2018-02-14T17:24:46+00:00" />
    
    <meta name="siteCoreBuildPath" content="//prod-aws.milbstatic.com/builds" />
    <meta name="siteCoreBuildVersionDirectory" content="79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/" />
    <meta name="sectionBuildVersion" content="3d4d9cc891e900f0e30bf386ef746ad79ba60272_1513702082" />
    
    <meta name="omniturePageName" content="Article" />
    
    <meta name="omniturePageProps" content="%7B%22pageName%22%3A%22news%22%2C%22registrationPoints%22%3A%22news%22%7D"/>
    
    <meta name="paywall" content="true"/>
    
    <meta name="apple-mobile-web-app-title" content="MiLB.com">
    
    <link rel="shortcut icon" href="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/images/favicon.ico">
    <link rel="apple-touch-icon" sizes="57x57" href="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/images/iOS/apple-icon-57x57.png" />
    <link rel="apple-touch-icon" sizes="72x72" href="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/images/iOS/apple-icon-72x72.png" />
    <link rel="apple-touch-icon" sizes="114x114" href="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/images/iOS/apple-icon-114x114.png" />
    <link rel="apple-touch-icon" sizes="144x144" href="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/images/iOS/apple-icon-144x144.png" />

    <!-- new relic -->
    
        <script type="text/javascript">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</script>
    

    <!-- avoid console log errors-->
    <script type="text/javascript">
    // Avoid `console` errors in browsers that lack a console.
    (function() {
        var method;
        var noop = function () {};
        var methods = [
            'assert', 'clear', 'count', 'debug', 'dir', 'dirxml', 'error',
            'exception', 'group', 'groupCollapsed', 'groupEnd', 'info', 'log',
            'markTimeline', 'profile', 'profileEnd', 'table', 'time', 'timeEnd',
            'timeStamp', 'trace', 'warn'
        ];
        var length = methods.length;
        var console = (window.console = window.console || {});
    
        while (length--) {
            method = methods[length];
    
            // Only stub undefined methods.
            if (!console[method]) {
                console[method] = noop;
            }
        }
    }());
    </script>

    <!-- device detection -->
    <!--[if lte IE 9]>
    <script type="text/javascript">
        window.location.replace("https://" + window.location.host + "/unsupported");
    </script>
    <![endif]-->
    <script type="text/javascript">
    
        !function(a,b){"function"!=typeof define||!define.amd||"undefined"!=typeof bam&&"function"==typeof bam.define?a.deviceBootstrap=b():define("../device",[],b)}(this,function(){function a(a,b){return a&&b?a[b]:a}function b(a){var b=a.split(w).slice(0,3);return a&&b.length<2&&b.push(0),b.join(".")}function c(a){return a=a||navigator.userAgent,D[a]?D[a]:this instanceof c?(D[a]=this,this.userAgent=a,this.is={},this.platform=this.getPlatform(),this.platformVersion=this.getPlatformVersion(),this.browser=this.getBrowser(),this.browserVersion=this.getBrowserVersion(),void(this.formFactor=this.getFormFactor())):new c(a)}var d="(",e=")",f="i",g="|",h="desktop",i="version",j="",k=function(a,b){return new RegExp(a,b||f)},l="iP(?:hone|ad|od)",m="(?:BlackBerry|BB10| RIM )",n="Android",o="Windows",p="WPDesktop",q=o+" Phone",r="Trident(?:.*?Touch(?:.*?Mobile))",s="Linux(?!.*Android)",t="Macintosh",u="CrOS",v=d+"?:"+[t,o,s,u].join(g)+e,w=/[\._]/,x={windowsphone:k(r+g+q+g+p),windows:k(o),ios:k(l),blackberry:k(m),android:k(n),linux:k(s),macintosh:k(t),chromebook:k(u)},y={desktop:/(?:Windows NT(?!.*WPDesktop)(?!.*Xbox))/i,tablet:k(d+["Tablet|iPad","\\sNT.*?"+r,n+"(?!.*Mobi)","silk",m+".*?Tablet","xbox"].join(g)+e),phone:k(d+["Mobi|Mobile","WPDesktop",l,r,m].join(g)+e)},z={tablet:k(d+["Tablet|iPad","\\sNT.*?"+r,n+"(?!.*Mobi)","silk",m+".*?Tablet"].join(g)+e),phone:k(d+["Mobi|Mobile",l,r,m].join(g)+e),desktop:k(v)},A={msie:/msie|iemobile|trident/i,edge:/edge/i,android:/android(?!.+(?:chrome|silk))/i,chrome:/chrome|crios/i,firefox:/firefox/i,opera:/opera(?!.*?mini)\//i,operamini:/opera mini/i,silk:/silk/i,safari:/safari/i},B={webkit:/AppleWebKit/i,gecko:/gecko\//i,trident:/trident/i,edge:/Edge/i},C={desktop:"desktop",other:h,phone:"phone",tablet:"tablet"},D={};return c.prototype={getPlatform:function(){return this.test(x)||h},getPlatformVersion:function(){return b(this.match(k("(?:"+(this.is.blackberry?i:this.platform)+"|"+q+"|OS)[^\\d]+([\\d\\.\\_]+)","ig"),1))},getBrowser:function(){return this.test(B),this.test(A)||h},getFormFactor:function(){var a="";return a=this.is.msie?y:z,C[this.test(a)]||C.other},getBrowserVersion:function(){var a=this.browser,c="[\\/\\s]";return this.is.chrome&&this.is.ios?a="crios":this.is.opera?a=i:this.is.msie&&(a=a+g+"IEMobile"+g+"rv",c="[\\/\\:\\s]"),b(this.match(k("(?:"+a+g+i+")"+c+"([\\d\\.]+)","i"),1))},match:function(b,c){return a(b.exec(this.userAgent),c)||j},test:function(a){var b,c,d,e=this.userAgent;for(b in a)c=a[b].test(e),this.is[b]=this.is[b]||c&&!d,c&&!d&&(d=b);return d}},c});
    
        //Device Detection
        (function(){
    
            window.getStartupDeviceTypeString = function() {
    
                var type = "";
    
                if (window.deviceBootstrap) {
                       type = !type ? window.deviceBootstrap().formFactor : type;
                } else {
                    console.error("Device Detection", "Module not loaded. Check /templates/meta.html. Pass ?device='[formFactor]' for testing");
                }
    
                return type;
            }
    
            document.getElementsByTagName('html')[0].className += ' device-' + getStartupDeviceTypeString();
    
        })();
    
    </script>

    <!-- CSS -->
    <script type="text/javascript">
        (function() {
    
            var siteLess = {"desktop":"site","tablet":"site","phone":"site"};
            var sectionLess = {"desktop":"section","tablet":"section","phone":"section"};
            var pageLess = {"desktop":"index","tablet":"index","phone":"index"};
            var type =  getStartupDeviceTypeString();
    
            if (siteLess[type]) {
                 document.write('<link rel="stylesheet" type="text/css" href="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/styles/'+siteLess[type]+'.css" />');
            }
    
            if (sectionLess[type]) {
                document.write('<link rel="stylesheet" type="text/css" href="//prod-aws.milbstatic.com/sections/news/builds/3d4d9cc891e900f0e30bf386ef746ad79ba60272_1513702082/styles/'+sectionLess[type]+'.css" />');
            }
    
            if (pageLess[type]) {
                document.write('<link rel="stylesheet" type="text/css" href="//prod-aws.milbstatic.com/sections/news/builds/3d4d9cc891e900f0e30bf386ef746ad79ba60272_1513702082/styles/'+pageLess[type]+'.css" />');
            }
        })();
    
    </script>
    
    

    <!-- paths to servers-->
    <script type="text/javascript">
     (function(){
        window.server_path = {"asset_server":"https://milb.bamcontent.com","cms_data":{"server":"https://s3.amazonaws.com","client":"https://s3.amazonaws.com","app_geo_directory":"/cms-milb-app-content-prod"},"control_plane":{"url":"","client_token":""},"form_service":"https://forms.mlbam.net/form-service","game_data":{"server":"","client":"","siteCode":"milb"},"legacy_server":"http://www.milb.com","live_fyre":{"livefyre_sitename":"milb.fyre.co","livefyre_countjs":"https://zor.livefyre.com/wjs/v1.0/javascripts/CommentCount.js","livefyre_siteId":"347758"},"parsely_site":"milb.com","recon_rest":"https://www.milb.com","recon_ws":"wss://www.milb.com","sdk":{"clientId":"sandbox","clientApiKey":"","environment":"prod","debugEnabled":false},"search":{"server":"https://search-api.milb.com","client":"https://search-api.milb.com","app_geo_directory":"milb_global"},"server":"https://www.milb.com","uistatic":"//prod-aws.milbstatic.com"};
     }());
    </script>

        <script type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "Home or away, prospects winning at love",
        "url": "https://www.milb.com/milb/news/home-or-away-prospects-winning-at-love/c-266053500",
        "dateCreated": "2018-02-14T15:00:00.000Z",
        "articleSection": "Top Headlines",
        "creator": ["Kelsie Heneghan"],
        "thumbnailUrl": "https://milb.bamcontent.comhttps://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/960x540/cut.jpg",
        "keywords": []
      }
    </script>

    <!-- paths to servers-->
    <style type="text/css">
        .primary-bg {
            background-color: #eeeeee;
        }
        .secondary-bg {
            background-color: #e20021;
        }
    </style>

</head>

<body id="news_article" class="lang-en_US">

<!-- header-->
<header>
    <nav class="container-fluid">

          

    </nav>
</header>

<!-- main content -->
<style type="text/css">
    .primary-bg {
        background-color: #eeeeee;
    }
    .secondary-bg {
        background-color: #e20021;
    }
</style>

<div class="main-content ">
    <header class="ad-banner">
        <div class="ad ad--top ad-responsive-slot primary-bg">
            <div id="ad-pushdown-xs-s" class="ad-responsive-size pull-center" data-thresholds="[0,1]" data-sizes="[[320,50]]" data-targeting="{&quot;pos&quot;:1,&quot;prdct&quot;:&quot;skins&quot;}"></div>
            <div id="ad-pushdown-md" class="ad-responsive-size pull-center" data-thresholds="[2]" data-sizes="[[468,60]]" data-targeting="{&quot;pos&quot;:1,&quot;prdct&quot;:&quot;skins&quot;}"></div>
            <div id="ad-pushdown-xl" class="ad-responsive-size pull-center" data-thresholds="[3,4,5,6]" data-sizes="[[728,90]]" data-targeting="{&quot;pos&quot;:1,&quot;prdct&quot;:&quot;skins&quot;}"></div>
        </div>
        <nav class='nav'>
            <a href='http://www.milb.com'>
                <i class="fa fa-angle-double-left" aria-hidden="true"></i>
                Back to MiLB.com
                 Home
            </a>
        </nav>
    </header>
    <span id="section-build-ver" data-section="/sections/news/builds/3d4d9cc891e900f0e30bf386ef746ad79ba60272_1513702082"></span>
    <div class="skin">
        <div class="template template--fluid section-news">
            <div id="search-bg"></div>
            <div id="filter-bg"></div>
            <header class="search-header">
              <div class="titles pull-left">
                <a class="milb-logo" href="http://www.milb.com"></a>
                  <h1 class="page-title"><a href="/milb/news">News</a></h1>
              </div>
              <div class="searchfield pull-right">
                <input type="text" id="searchfield" placeholder="Search News">
                <i class="fa fa-search" id="search-btn" aria-hidden="true"></i>
              </div>
              <div class="searchfield pull-right device">
                <i class="fa fa-search search-device" aria-hidden="true"></i>
              </div>
            </header>
            <header class="searchfield device">
              <i class="fa fa-times-circle" aria-hidden="true"></i>
              <input type="text" id="searchfield-device" placeholder="Search News" value="">
            </header>
            <header class="filter-header">
              <div class="form-inline">
                <div class="form-group hidden">
                  <div class="menu-dropdown input-group">
                    <button class="btn btn-default dropdown-toggle" type="button" id="topic-dropdown" data-toggle="dropdown" aria-haspopup="true" aria-expanded="true">
                      <i class="fa fa-angle-down" aria-hidden="true"></i>
                    </button>
                  </div>
                </div>
                <label class="menu-label">
                    Now Reading:  <span>Top Headlines</span>
                 </label>
                <div class="filter-group form-group pull-right">
                  <label class="select-label">Filter Search By:</label>
                  <div class="select-dropdown input-group">
                    <div class="input-group-btn">
                      <input type="text" class="form-control" id="monthfield" placeholder="Month" value="" tabindex="-1">
                      <button class="btn btn-default dropdown-toggle" type="button" id="month-dropdown" data-toggle="dropdown" aria-haspopup="true" aria-expanded="true"">
                        <i class="fa fa-sort-desc" aria-hidden="true"></i>
                      </button>
                      <ul class="dropdown-menu" aria-labelledby="month-dropdown">
                        <li><a href="#" data-index="1">January</a></li>
                        <li><a href="#" data-index="2">February</a></li>
                        <li><a href="#" data-index="3">March</a></li>
                        <li><a href="#" data-index="4">April</a></li>
                        <li><a href="#" data-index="5">May</a></li>
                        <li><a href="#" data-index="6">June</a></li>
                        <li><a href="#" data-index="7">July</a></li>
                        <li><a href="#" data-index="8">August</a></li>
                        <li><a href="#" data-index="9">September</a></li>
                        <li><a href="#" data-index="10">October</a></li>
                        <li><a href="#" data-index="11">November</a></li>
                        <li><a href="#" data-index="12">December</a></li>
                      </ul>
                    </div>
                  </div>
                  <div class="select-dropdown input-group">
                    <div class="input-group-btn">
                      <input type="text" class="form-control" id="yearfield" placeholder="Year" value="" tabindex="-1">
                      <button class="btn btn-default dropdown-toggle" type="button" id="year-dropdown" data-toggle="dropdown" aria-haspopup="true" aria-expanded="true">
                        <i class="fa fa-sort-desc" aria-hidden="true"></i>
                      </button>
                      <ul class="dropdown-menu" id="year-dropdown" aria-labelledby="year-dropdown">
                        <li><a href="#">2018</a></li>
                        <li><a href="#">2017</a></li>
                        <li><a href="#">2016</a></li>
                        <li><a href="#">2015</a></li>
                        <li><a href="#">2014</a></li>
                        <li><a href="#">2013</a></li>
                        <li><a href="#">2012</a></li>
                        <li><a href="#">2011</a></li>
                        <li><a href="#">2010</a></li>
                        <li><a href="#">2009</a></li>
                        <li><a href="#">2008</a></li>
                        <li><a href="#">2007</a></li>
                        <li><a href="#">2006</a></li>
                        <li><a href="#">2005</a></li>
                      </ul>
                    </div>
                  </div>
                  <div class="btn btn-search " id="btn-search">GO</div>
                </div>
              </div>
            </header>
            <div class="template__container">
                    <div class="template--article__content">
                        <article class="article-item article-item--expanded article-item--active"
                            data-contentId="266053500"
                            data-index="0"
                            data-title="Home or away, prospects winning at love"
                            data-keywords="[{&quot;type&quot;:&quot;player_id&quot;,&quot;value&quot;:&quot;669746&quot;,&quot;displayName&quot;:&quot;Eveld, Tommy&quot;},{&quot;type&quot;:&quot;player_id&quot;,&quot;value&quot;:&quot;642215&quot;,&quot;displayName&quot;:&quot;Wilson, Weston&quot;},{&quot;type&quot;:&quot;player_id&quot;,&quot;value&quot;:&quot;665321&quot;,&quot;displayName&quot;:&quot;Schwaab, Andrew&quot;}]"
                            data-dateCreated="February 14, 2018 10:00 AM ET"
                            data-author="Kelsie Heneghan"
                            data-game-id=""
                            data-url="/milb/news/home-or-away-prospects-winning-at-love/c-266053500"
                            data-primary-keyword="">
                            <div class="article-item-keywords" data-keywords="nyy_prospect_news, milb_news, 43, long_reads, 669746, news_aa, mil_prospect_news, news_aaa, heneghan_kelsie, news_rookie, news_full, ari_prospect_news, 642215, 665321, news_advanced, news_short, 3, 1706, 95, "></div>
                        
                            <div class="article-item__top">
                                <span class="article-item__primary-tag" data-type="" data-value=""></span>
                                <span class="article-item__game-data"></span>
                                <div class="article-item__recap" data-shareable="true"></div>
                                <h1 class="article-item__headline">Home or away, prospects winning at love</h1>
                        
                                    <h2 class="article-item__subheader">Long-distance relationships challenge Minor Leaguers off the field</h2>
                        
                                  <div class="social-share__wrapper first"
                                       data-shareable="true"
                                       data-index="0"
                                       data-site="milb"
                                       data-sitecode="milb"
                                       data-slug="home-or-away-prospects-winning-at-love"
                                       data-title="Home or away, prospects winning at love"
                                       data-url="/milb/news/home-or-away-prospects-winning-at-love/c-266053500"
                                       data-contentId="266053500"></div>
                            </div>
                        
                            <div class="article-item__img-container">
                                        <img alt="" class="article-item__img "
                                        	     src="https://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/960x540/cut.jpg"
                                        	title=""
                                          onerror="this.onerror=null;this.src='/site-core/images/MiLB_image_placeholder.png';this.parentNode.style.height='100%';this.removeAttribute('srcset');"
                                        	data-srcset="https://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/960x540/cut.jpg 960w"
                                        	sizes="(min-width: 1308px) 943px, (min-width: 1024px) 66.6667vw, 100vw">
                        
                            </div>
                        
                            <p class="article-item__caption">Tommy Eveld, Weston Wilson and Andrew Schwaab all proposed to their respective girlfriends before games during the 2017 season. </p>
                        
                            <p class="article-item__credit">
                                By Kelsie Heneghan / MiLB.com | February 14, 2018 10:00 AM ET
                            </p>
                        
                            <div class="article-item__bottom">
                                <div class="article-item__component article-item__linescore hidden"></div>
                                <div class="article-item__preview"><p><span class="token token-playerCard" id="token-C411C30796BA1FB2489A3">Andrew Schwaab</span> sat alone in the dugout, staring at the rain. With the rest of the Florida State League's top players in the clubhouse, the Yankees pitching prospect just watched it come down, worried about what was going to happen.</p>
                        
                        <p>But it wasn't his opportunity to play in an All-Star Game that had Schwaab fearful of a cancellation. It was what he'd planned beforehand.</p>
                        
                        <p>Like Brewers prospect <span class="token token-playerCard" id="token-2BD98090DB3FD8DCD4982">Weston Wilson</span> and D-backs prospect <span class="token token-playerCard" id="token-A511747A8AEDC6373CAA6">Tommy Eveld</span> had done a month prior, Schwaab was set to propose to his girlfriend after she threw out a ceremonial first pitch.</p></div>
                                <div class="article-item__body"><p>As if following a movie script, the clouds parted, the rain stopped and Schwaab was able to get on bended knee to pop the question to Lauren Stoeckle, who -- of course -- said yes.</p>
                        
                        <p>While it was a special moment, the time before and after hasn't always been idyllic, with more conversations on FaceTime than face-to-face. But it was always worth it.</p>
                        
                        <p>"Being on the road and going through this with your partner and not seeing them for so long and then being there for them when they have a bad outing or even when they have a good outing, you have to be prepared to be on the other end of it, which is our hardest role as fianc&#233;s, girlfriends," Stoeckle said. "As their supporters, we have to get through a lot together. I think baseball players have it pretty tough, but the baseball girls have it tough as well."</p>
                        
                        <p class="u-text-center">***</p>
                        
                        <p>A month after <b><span class="token token-hyperLink" id="token-E32B35A2998FE9BFCA599"><a href="https://www.milb.com/milb/news/daytona-tortugas-gavin-lavalley-homers-twice-in-florida-state-league-all-star-game/c-237196122">the June 17 proposal</a></span></b>, Schwaab gave Stoeckle another big surprise at a stadium. With his sister and brother-in-law in town, the 24-year-old called his fianc&#233; back to the field. Stoeckle walked down the steps at George M. Steinbrenner Field to the barrier, "because, let's be honest, there's always that wall between us and them when they're on the field."</p>
                        
                        <p>That literal separation was about to get much bigger as Schwaab informed Stoeckle and his family that he was being promoted to Double-A Trenton.</p>
                        
                        <p>"I had no thoughts in that moment. It was pretty surreal, but he had absolutely deserved it. It was a good moment," she said. "It was [tough], just because we were still on our engagement high and I wasn't really prepared to let him go again because I didn't know when I was going to be able to see him again."</p>
                        
                        <p><span class="token token-photo" id="token-EFAB1D7D86C1C239914A0"><!--266107344--></span></p>
                        
                        <p><i>Andrew Schwaab and Lauren Stoeckle embrace after she said yes. (Tom Hagerty/MiLB.com)</i></p>
                        
                        <p>Schwaab and Stoeckle had gotten used to being apart. While they met in a communications class at the University of Missouri, the latter transferred to the University of Arizona for the swim team about a month and a half into the relationship.</p>
                        
                        <p>The pair planned FaceTime dates to watch Netflix together and catch each other up on their days. Stoeckle tuned in to watch Schwaab pitch for Mizzou and, eventually, the Yankees after they signed him in June 2015.</p>
                        
                        <p>When Stoeckle graduated in 2016, she moved to Seattle for an account coordinator position in sales and marketing. That fall, Schwaab joined her and began their longest stretch of living together. The right-hander predicted he would be in the Florida State League for most of 2017, so Stoeckle got permission to work remotely as the pair moved to Tampa for Spring Training.</p>
                        
                        <p>"It's actually really nice because normally we would go a month or two without seeing each other and then we would only visit for like maybe a week and then go another few months," he said of finally getting together. "So it was tough battling that for a while."</p>
                        
                        <p class="u-text-center">***</p>
                        
                        <p>Weston's high with his now-wife Madison also got cut short when he was sent down from Class A Advanced Carolina to Class A Wisconsin on June 22, seven weeks after the proposal. Getting the news while on a beach during the All-Star break, the 23-year-old and his fianc&#233; were taken aback.</p>
                        
                        <p>Exactly three months from their wedding date, the planning was about to get stressful for Weston and Madison, although timing had never been a problem. They met in December 2016 and were <b><span class="token token-hyperLink" id="token-8E017B4667442C47E8CBF"><a href="https://www.milb.com/milb/news/milwaukee-brewers-prospect-weston-wilson-proposes-at-carolina-mudcats-game/c-228712344">engaged the following May at the Mudcats game</a></span></b>&nbsp;after securing the blessing from Madison's dad. (Getting that proved a little difficult initially as Weston dialed the wrong number and began asking a stranger for his daughter's hand.)</p>
                        
                        <p>"I would've married him the day that I met him, and I'm not like that. But I knew it right away, so I was very happy that he did, but I was so nervous," Madison said with a laugh. "I remember seeing the camera guy in my peripheral vision, so close to my face and I was trying not to cry and I couldn't even breathe. But I was so happy."</p>
                        
                        <p><span class="token token-video" id="token-30C1CED34D3890FE136A0"><a href="http://m.milb.com/video/v1359879283">Video: Mudcat proposes after first pitch</a></span></p>
                        
                        <p>While Weston was in Wisconsin, Madison put her modeling career on the back burner and began planning with her mom and future mother-in-law. The Brewers prospect felt bad he couldn't participate but knew his then-fianc&#233; understood the circumstances.</p>
                        
                        <p>The demotion in the middle of wedding planning may have led to a tough adjustment as Weston went hitless in his first four games with the Timber Rattlers as part of a 6-for-31 (.194) stretch. That's when the Clemson product had to remind himself why he deals with the slumps and the distance from loved ones.</p>
                        
                        <p>"I just had to put things in perspective. Like baseball is what I'm doing, but it's for a greater purpose," he said. "I'm always thinking about Madison and the family that we're going to have one day. We are a family right now, but providing for our kids and just looking forward to that."</p>
                        
                        <p class="u-text-center">***</p>
                        
                        <p>Eveld and Erica Nunn had a system when they first started dating. He was on the football team and she played softball at the University of South Florida. With the opposite seasons, they could attend each other's games. Then Eveld switched to baseball his junior year and things got complicated.</p>
                        
                        <p>While their schedules didn't match up, their stadiums were right next to each other, so Eveld would catch a few innings of softball before his game started and Nunn could watch the end of the baseball games.</p>
                        
                        <p>"We were just so busy with practice and games that I didn't really think of it that much," she said of the time apart. "But whenever we had off days, we would always hang out. I guess that's where we got our first taste of it."</p>
                        
                        <p>Eveld was drafted by the D-backs in 2016, while Nunn went to North Carolina State for grad school. Crossing time zones, Nunn stayed up late to watch Eveld pitch for Class A Short Season Eugene, noting that she had to watch the whole game since he was the Emeralds' closer.</p>
                        
                        <p>The 6-foot-5 right-hander said he doesn't worry about the distance, noting it wouldn't matter if he was in the Carolina League or Japan.</p>
                        
                        <p>"We're pretty happy with what we got," he said. "I guess I'm just thankful that we don't have the hiccups and that she understands what the Minor League life is."</p>
                        
                        <blockquote class="instagram-media" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/zgSUXeFoRg/" data-instgrm-version="8" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);">
                        <div style="padding:8px;">
                        	<div style=" background:#F8F8F8; line-height:0; margin-top:40px; padding:50% 0; text-align:center; width:100%;">
                        		<div style=" background:url(data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAACwAAAAsCAMAAAApWqozAAAABGdBTUEAALGPC/xhBQAAAAFzUkdCAK7OHOkAAAAMUExURczMzPf399fX1+bm5mzY9AMAAADiSURBVDjLvZXbEsMgCES5/P8/t9FuRVCRmU73JWlzosgSIIZURCjo/ad+EQJJB4Hv8BFt+IDpQoCx1wjOSBFhh2XssxEIYn3ulI/6MNReE07UIWJEv8UEOWDS88LY97kqyTliJKKtuYBbruAyVh5wOHiXmpi5we58Ek028czwyuQdLKPG1Bkb4NnM+VeAnfHqn1k4+GPT6uGQcvu2h2OVuIf/gWUFyy8OWEpdyZSa3aVCqpVoVvzZZ2VTnn2wU8qzVjDDetO90GSy9mVLqtgYSy231MxrY6I2gGqjrTY0L8fxCxfCBbhWrsYYAAAAAElFTkSuQmCC); display:block; height:44px; margin:0 auto -44px; position:relative; top:-22px; width:44px;">
                        			 
                        		</div>
                        	</div>
                        	<p style=" margin:8px 0 0 0; padding:0 4px;"><span class="token token-hyperLink" id="token-0AF8AE075DB5E33ABA19F"><a href="https://www.instagram.com/p/zgSUXeFoRg/" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">&#10084; #loveyou</a></span></p>
                        
                        	<p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <span class="token token-hyperLink" id="token-FA808CE42CBB5BDE19F84"><a href="https://www.instagram.com/udontwant_nunn/" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Erica Nunn</a></span> (@udontwant_nunn) on <time datetime="2015-02-25T00:43:53+00:00" style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;">Feb 24, 2015 at 4:43pm PST</time></p>
                        </div>
                        </blockquote>
                        <script async="" defer="defer" src="//www.instagram.com/embed.js"></script>
                        
                        <p>Getting a stable job at a software company in North Carolina after grad school, Nunn focuses on the fact that the season runs only from February to September. Admitting she's become much more of a planner with their lifestyle, the former All-American softball pitcher has learned how to buy redeemable flights and use vacation days strategically as midseason promotions can happen when you least expect them -- like six weeks <b><span class="token token-hyperLink" id="token-358F655374245F7533895"><a href="https://www.milb.com/milb/news/prospect-qa-eveld-enjoys-easy-transition/c-214856702">after a proposal</a></span></b>.</p>
                        
                        <p>"He loves it. I don't think he's ever been mad or sad when he's out during the season," she said. "He always have a positive attitude, is always willing to work and do the extra stuff to get him to where he wants to go. That's what makes it worth it."</p>
                        
                        <p>With her softball background, Nunn not only understands her fianc&#233;s passion, she understands pitching.</p>
                        
                        <p>"I lucked out. I'm fairly new to the more advanced type of baseball with all the film studying and just learning the game, and she's got a couple years of that under her belt already from being at USF," Eveld said. "She'll actually call me sometimes and talk baseball with me and be like, 'Hey, what were you thinking when you were throwing to this guy? Why did you throw this pitch there and why weren't you thinking &#8230; maybe you should've thrown your curveball instead of fastball again.' She can give me pointers and advice that it's almost like having another pitching coach."</p>
                        
                        <p class="u-text-center">***</p>
                        
                        <p>After an offseason enjoying married life for the Wilsons and planning their upcoming nuptials for Schwaab and Stoeckle, and Eveld and Nunn, the 2018 season figures to bring back old challenges.</p>
                        
                        <p>Madison will continue modeling in Los Angeles or Miami, while Weston heads to Carolina or Double-A Biloxi; in April, Stoeckle will move to Denver for work and finalize wedding plans while Schwaab likely will be in Trenton or Triple-A Scranton/Wilkes-Barre; and Nunn will keep working in North Carolina while Eveld plays for Class A Advanced Visalia or Double-A Jackson, which would be a nine-hour drive from his fianc&#233; and family.</p>
                        
                        <p>"It's easy to make it work because our relationship is so strong," Madison said. "It's just hard to be apart because I don't like to be away from him."</p>
                        
                        <p>Thinking about the keys to making things work, communication, trust, understanding and love came up a lot, of course, with commitment being the underlying factor.</p>
                        
                        <p>"If he wasn't committed to the sport the way he is, he wouldn't be doing it, he wouldn't be where he is, he wouldn't be as successful as he is," Stoeckle said of Schwaab. "If we weren't committed to each other, we wouldn't be suffering the distance, we would've definitely chosen a different path because this is not for the faint of heart, this entire lifestyle. So I definitely think commitment and just loving each other is probably the best key to it all."</p>
                        
                        <p>While Valentine's Day is viewed as commercial by some, it also marks something Minor League couples don't take for granted. With college opening days and Spring Training report dates usually falling on or before Feb. 14, they're typically separated.</p>
                        
                        <p>Occasionally, however, things work out: with Stoeckle still in Tampa, she "actually" gets to be with Schwaab for the second Valentine's Day in a row.</p>
                        
                        <p>"I don't know about next year or the year after that, but I'm going to take this one for what I can and we're going to enjoy it," she said. "I'm not sure what we're going to do, but I know we'll just enjoy being together."</p></div>
                        
                                <p class="article-item__tagline"><b>Kelsie Heneghan</b> is a contributor to MiLB.com. Follow her on Twitter <b><a href="http://twitter.com/Kelsie_Heneghan" >@Kelsie_Heneghan</a></b>.
                                
                        
                                
                        
                                This story was not subject to the approval of the National Association of Professional Baseball Leagues or its clubs.
                        
                                
                                </p>
                        
                                <a href="/milb/news/home-or-away-prospects-winning-at-love/c-266053500"
                                  class="btn btn-primary article-item__more"
                                  aria-label="Home or away, prospects winning at love"
                                  data-contentId=266053500>View More</a>
                        
                                <div class="article-item__component article-item__featured-players hidden"></div>
                        
                                <div class="article-item__component article-item__outbrain hidden"></div>
                        
                                  <div class="social-share__wrapper last hidden"
                                       data-shareable="true"
                                       data-index="0"
                                       data-site="milb"
                                       data-sitecode="milb"
                                       data-slug="home-or-away-prospects-winning-at-love"
                                       data-title="Home or away, prospects winning at love"
                                       data-url="/milb/news/home-or-away-prospects-winning-at-love/c-266053500"
                                       data-contentId="266053500"></div>
                        
                                <button class="btn btn-primary article-item__less article-item__toggle">View Less</button>
                            </div>
                        
                            <span class="token-data" data-token-data="{&quot;token-0AF8AE075DB5E33ABA19F&quot;:{&quot;tokenGUID&quot;:&quot;token-0AF8AE075DB5E33ABA19F&quot;,&quot;type&quot;:&quot;hyperLink&quot;,&quot;href&quot;:&quot;https://www.instagram.com/p/zgSUXeFoRg/&quot;,&quot;hrefMobile&quot;:&quot;https://www.instagram.com/p/zgSUXeFoRg/&quot;,&quot;target&quot;:&quot;_blank&quot;,&quot;style&quot;:&quot; color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;&quot;},&quot;token-FA808CE42CBB5BDE19F84&quot;:{&quot;tokenGUID&quot;:&quot;token-FA808CE42CBB5BDE19F84&quot;,&quot;type&quot;:&quot;hyperLink&quot;,&quot;href&quot;:&quot;https://www.instagram.com/udontwant_nunn/&quot;,&quot;hrefMobile&quot;:&quot;https://www.instagram.com/udontwant_nunn/&quot;,&quot;target&quot;:&quot;_blank&quot;,&quot;style&quot;:&quot; color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;&quot;},&quot;token-30C1CED34D3890FE136A0&quot;:{&quot;tokenGUID&quot;:&quot;token-30C1CED34D3890FE136A0&quot;,&quot;type&quot;:&quot;video&quot;,&quot;videoId&quot;:&quot;1359879283&quot;,&quot;href&quot;:&quot;http://m.milb.com/video/v1359879283&quot;,&quot;tags&quot;:[{&quot;@type&quot;:&quot;mmtax&quot;,&quot;@value&quot;:&quot;embeddable&quot;,&quot;@displayName&quot;:&quot;Blog embeddable (internal)&quot;},{&quot;@type&quot;:&quot;subject&quot;,&quot;@value&quot;:&quot;MILB_NO_TRANSCODE&quot;,&quot;@displayName&quot;:&quot;MILB_NO_TRANSCODE&quot;},{&quot;@type&quot;:&quot;authflow&quot;,&quot;@value&quot;:&quot;false&quot;,&quot;@displayName&quot;:&quot;false&quot;},{&quot;@type&quot;:&quot;subject&quot;,&quot;@value&quot;:&quot;MILB_FEATURE&quot;,&quot;@displayName&quot;:&quot;MILB_FEATURE&quot;},{&quot;@type&quot;:&quot;milbtax&quot;,&quot;@value&quot;:&quot;highlight&quot;,&quot;@displayName&quot;:&quot;highlight&quot;},{&quot;@type&quot;:&quot;milbtax&quot;,&quot;@value&quot;:&quot;mil_affiliate&quot;,&quot;@displayName&quot;:&quot;Brewers Affiliate&quot;},{&quot;@type&quot;:&quot;team_id&quot;,&quot;@value&quot;:&quot;249&quot;,&quot;@displayName&quot;:&quot;Carolina Mudcats&quot;},{&quot;@type&quot;:&quot;milbtax&quot;,&quot;@value&quot;:&quot;carolina&quot;,&quot;@displayName&quot;:&quot;Carolina League&quot;},{&quot;@type&quot;:&quot;player_id&quot;,&quot;@value&quot;:&quot;642215&quot;,&quot;@displayName&quot;:&quot;Weston Wilson&quot;},{&quot;@type&quot;:&quot;mmtax&quot;,&quot;@value&quot;:&quot;shareable&quot;,&quot;@displayName&quot;:&quot;FB shareable (internal)&quot;},{&quot;@type&quot;:&quot;milbtax&quot;,&quot;@value&quot;:&quot;class_a_advanced&quot;,&quot;@displayName&quot;:&quot;Class A Advanced&quot;},{&quot;@type&quot;:&quot;combined_media_state&quot;,&quot;@value&quot;:&quot;MEDIA_ARCHIVE&quot;,&quot;@displayName&quot;:&quot;MEDIA_ARCHIVE&quot;},{&quot;@type&quot;:&quot;mmtax&quot;,&quot;@value&quot;:&quot;club_produced&quot;,&quot;@displayName&quot;:&quot;Club-produced Content&quot;}],&quot;date&quot;:&quot;2017-05-06T21:44:45-0400&quot;,&quot;headline&quot;:&quot;Mudcat proposes after 1st pitch&quot;,&quot;duration&quot;:&quot;00:02:39&quot;,&quot;blurb&quot;:&quot;Mudcat proposes after first pitch&quot;,&quot;bigBlurb&quot;:&quot;Carolina Mudcats&#x27; Weston Wilson proposes to his girlfriend after a first pitch&quot;,&quot;previewImage&quot;:&quot;http://media.minorleaguebaseball.com/milb/2017/05/07/images/milbf_1359879283_th_45.jpg&quot;,&quot;mediaURLS&quot;:{&quot;FLASH_1000K_640X360&quot;:&quot;http://media.minorleaguebaseball.com/milb/2017/05/07/milb_1359879283_1m.mp4&quot;,&quot;FLASH_600K_400X224&quot;:&quot;http://media.minorleaguebaseball.com/milb/2017/05/07/milb_1359879283_600K.mp4&quot;}},&quot;token-EFAB1D7D86C1C239914A0&quot;:{&quot;tokenGUID&quot;:&quot;token-EFAB1D7D86C1C239914A0&quot;,&quot;type&quot;:&quot;photo&quot;,&quot;photoId&quot;:&quot;266107344&quot;,&quot;secondary&quot;:false,&quot;internalName&quot;:&quot;Schwaab proposal&quot;,&quot;title&quot;:&quot;&quot;,&quot;altText&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Andrew Schwaab and Lauren Stoeckle embraced after she said yes. (Tom Hagerty/MiLB.com)&quot;,&quot;credit&quot;:&quot;&quot;,&quot;class&quot;:&quot;&quot;,&quot;hrefVal&quot;:&quot;https://.milb.com/assets/images/3/4/4/266107344/cuts/960x540/cut.jpg&quot;,&quot;cuts&quot;:{&quot;960x540&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:960,&quot;height&quot;:540,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/960x540/cut.jpg&quot;},&quot;640x360&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:640,&quot;height&quot;:360,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/640x360/cut.jpg&quot;},&quot;480x270&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:480,&quot;height&quot;:270,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/480x270/cut.jpg&quot;},&quot;320x180&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:320,&quot;height&quot;:180,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/320x180/cut.jpg&quot;},&quot;300x169&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:300,&quot;height&quot;:169,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/300x169/cut.jpg&quot;},&quot;265x150&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:265,&quot;height&quot;:150,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/265x150/cut.jpg&quot;},&quot;160x90&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:160,&quot;height&quot;:90,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/160x90/cut.jpg&quot;},&quot;124x70&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:124,&quot;height&quot;:70,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/124x70/cut.jpg&quot;},&quot;96x54&quot;:{&quot;aspectRatio&quot;:&quot;16:9&quot;,&quot;width&quot;:96,&quot;height&quot;:54,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/96x54/cut.jpg&quot;},&quot;300x200&quot;:{&quot;aspectRatio&quot;:&quot;3:2&quot;,&quot;width&quot;:300,&quot;height&quot;:200,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/300x200/cut.jpg&quot;},&quot;222x168&quot;:{&quot;aspectRatio&quot;:&quot;4:3&quot;,&quot;width&quot;:222,&quot;height&quot;:168,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/222x168/cut.jpg&quot;},&quot;215x160&quot;:{&quot;aspectRatio&quot;:&quot;4:3&quot;,&quot;width&quot;:215,&quot;height&quot;:160,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/215x160/cut.jpg&quot;},&quot;148x112&quot;:{&quot;aspectRatio&quot;:&quot;4:3&quot;,&quot;width&quot;:148,&quot;height&quot;:112,&quot;src&quot;:&quot;/assets/images/3/4/4/266107344/cuts/148x112/cut.jpg&quot;}}},&quot;token-8E017B4667442C47E8CBF&quot;:{&quot;tokenGUID&quot;:&quot;token-8E017B4667442C47E8CBF&quot;,&quot;type&quot;:&quot;hyperLink&quot;,&quot;href&quot;:&quot;https://www.milb.com/milb/news/milwaukee-brewers-prospect-weston-wilson-proposes-at-carolina-mudcats-game/c-228712344&quot;,&quot;hrefMobile&quot;:&quot;https://www.milb.com/milb/news/milwaukee-brewers-prospect-weston-wilson-proposes-at-carolina-mudcats-game/c-228712344&quot;},&quot;token-E32B35A2998FE9BFCA599&quot;:{&quot;tokenGUID&quot;:&quot;token-E32B35A2998FE9BFCA599&quot;,&quot;type&quot;:&quot;hyperLink&quot;,&quot;href&quot;:&quot;https://www.milb.com/milb/news/daytona-tortugas-gavin-lavalley-homers-twice-in-florida-state-league-all-star-game/c-237196122&quot;,&quot;hrefMobile&quot;:&quot;https://www.milb.com/milb/news/daytona-tortugas-gavin-lavalley-homers-twice-in-florida-state-league-all-star-game/c-237196122&quot;},&quot;token-358F655374245F7533895&quot;:{&quot;tokenGUID&quot;:&quot;token-358F655374245F7533895&quot;,&quot;type&quot;:&quot;hyperLink&quot;,&quot;href&quot;:&quot;https://www.milb.com/milb/news/prospect-qa-eveld-enjoys-easy-transition/c-214856702&quot;,&quot;hrefMobile&quot;:&quot;https://www.milb.com/milb/news/prospect-qa-eveld-enjoys-easy-transition/c-214856702&quot;},&quot;token-C411C30796BA1FB2489A3&quot;:{&quot;tokenGUID&quot;:&quot;token-C411C30796BA1FB2489A3&quot;,&quot;type&quot;:&quot;playerCard&quot;,&quot;id&quot;:&quot;665321&quot;,&quot;position&quot;:&quot;1&quot;,&quot;name&quot;:&quot;Andrew Schwaab&quot;,&quot;seoName&quot;:&quot;andrew-schwaab&quot;},&quot;token-2BD98090DB3FD8DCD4982&quot;:{&quot;tokenGUID&quot;:&quot;token-2BD98090DB3FD8DCD4982&quot;,&quot;type&quot;:&quot;playerCard&quot;,&quot;id&quot;:&quot;642215&quot;,&quot;position&quot;:&quot;3&quot;,&quot;name&quot;:&quot;Weston Wilson&quot;,&quot;seoName&quot;:&quot;weston-wilson&quot;},&quot;token-A511747A8AEDC6373CAA6&quot;:{&quot;tokenGUID&quot;:&quot;token-A511747A8AEDC6373CAA6&quot;,&quot;type&quot;:&quot;playerCard&quot;,&quot;id&quot;:&quot;669746&quot;,&quot;position&quot;:&quot;1&quot;,&quot;name&quot;:&quot;Tommy Eveld&quot;,&quot;seoName&quot;:&quot;tommy-eveld&quot;}}"></span>
                        
                        </article>
                    </div>
                        <nav class="template--article__sidebar">
                            <div class="template--article__sidebar--wrapper">
                                <ul class="article-sidebar-list">
                                    <li class="article-sidebar-item lazy" data-contentId="266053500" data-primary-keyword="">
                                        <div class="media-left article-sidebar-item__meta">
                                            <a href="/milb/news/home-or-away-prospects-winning-at-love/c-266053500">
                                                 <img class="media-object" src="https://milb.bamcontent.com/assets/images/0/4/8/266054048/cuts/124x70/cut.jpg">
                                            </a>
                                        </div>
                                        <div class="media-body article-sidebar-item__meta">
                                            <h5 class="article-sidebar-item__meta-headline">Home or away, prospects winning at love</h5>
                                            <span class="article-sidebar-item__meta-tag">
                                                  2 hours ago
                                            </span>
                                        </div>
                                        <hr class='article-sidebar-item__border-stripe'>
                                    </li>
                                </ul>
                            </div>
                        </nav>
            </div>
        </div>
    </div>
    <div id="temp-article" style="display: none !important;"></div>
</div>

<div class="ad-responsive-slot ad-outofpage">
    <div
        id="ad-skin"
        class="ad-responsive-size"
        data-thresholds="[6,7]"
        data-targeting="{&quot;pos&quot;:1,&quot;prdct&quot;:&quot;skins&quot;}"></div>
</div>
<div class="ad-responsive-slot">
    <div
        id="33-across"
        class="ad-responsive-size"
        data-thresholds="[0,1,2,3,4,5,6,7]"
        data-sizes="[[1,3]]"
        data-targeting="{&quot;pos&quot;:1,&quot;prdct&quot;:&quot;skins&quot;}"
    ></div>
</div>

<script type="text/javascript" src='https://widgets.outbrain.com/outbrain.js'></script>
<script type="text/javascript" src='/sections/news/bower_components/jquery/jquery.min.js'></script>
<script type="text/javascript" src='/sections/news/bower_components/milb-theme/dist/milb-theme.js'></script>
<script type="text/javascript" src='/sections/news/scripts/3p/VisitorAPI.js'></script>
<script type="text/javascript" src='/sections/news/scripts/3p/AppMeasurement.js'></script>

<script type="text/javascript">
    // this script block is used to bring data from server to front end
    var MiLB_ARTICLES = {}; // set up the var key name here.

    // normalize the keywordsAll array object with this throwaway function.
    MiLB_ARTICLES.keywordsNormalize = function ( str ) {
        return str.replace( /&quot;/g, "\"" ).replace( /&#x27;/g, "\\'" );
    };

    MiLB_ARTICLES.getTopicTopicId = function(pageId, value, type) {
        return JSON.parse(pageId === 'news-search' ? value : type);
    };

    MiLB_ARTICLES.getTopicTopicPage = function(pageId, value, type) {
        return JSON.parse(pageId === 'news-search' ? value : type);
    };

    MiLB_ARTICLES.getTopicId = function() {};

    // define the rest of MiLB_ARTICLES
    MiLB_ARTICLES = {
        page: 'article',
        siteCode: 'milb',
        siteID: 'milb',
        fullName: 'MiLB',
        articlePage: 'true',
        topicId: MiLB_ARTICLES.getTopicTopicId('article', '', '185364810'),
        topicPage: MiLB_ARTICLES.getTopicTopicPage('article', '', 'false'),
        gamePk: '' || null,
        club: 'milb',
        lang: '',
        server: 'https://www.milb.com' || '',
        cmsServer: 'https://s3.amazonaws.com/cms-milb-app-content-prod' || '',
        teamNameFull: '' || '',
        playerId: isNaN(parseInt('', 10)) ? null : parseInt('', 10),
        fillBySearch: 'true' === 'true',
        topicSponsor: '',
        articleSponsor: '',
        keywords: '' || [],
        keywordsAll: MiLB_ARTICLES.keywordsNormalize( '[{&quot;type&quot;:&quot;team_file_code&quot;,&quot;value&quot;:&quot;milb&quot;,&quot;displayName&quot;:&quot;MiLB&quot;},{&quot;type&quot;:&quot;type&quot;,&quot;value&quot;:&quot;article&quot;,&quot;displayName&quot;:&quot;Article Topic List&quot;},{&quot;type&quot;:&quot;language&quot;,&quot;value&quot;:&quot;en&quot;,&quot;displayName&quot;:&quot;English&quot;}]' ) || {},
        locale: 'en',
        livefyreSiteId: '347758',
        contextUrlPrefix: '/milb',
        startBySearch: '' === 'true',
        commentsOpen: window.location.href.indexOf('comments=1') > 0,
        contentId: '266053500',
        searchUrl: '',
        parsely: '',
        search: {
            query: 'tag_archive-element:milb_news' || null,
            fromDate: '' || null,
            toDate: '' || null,
            page: '' === 'true' ? 2 : 1
        }
    };
</script>

<script>
    PARSELY = {
        autotrack: false,
        track: function(url, action, data) {
            var urlref = document.referrer;
            var obj = {
                url: url,
                urlref: urlref,
                js: 1,
                action_name: action,
                data: data
            };

            if (action === 'Read Less') {
                obj.action = action;
            }

            if (data._viewport === 'article') {
                obj.action = 'Article View';
            }

            if (PARSELY.beacon && PARSELY.beacon.trackPageView) {
                PARSELY.beacon.trackPageView(obj);
                return true;
            }
        }
    };
</script>

<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
    <div id="parsely-cfg" data-parsely-site="milb.com"></div>
</div>
<script>
    (function(s, p, d) {
        var h=d.location.protocol, i=p+"-"+s,
                e=d.getElementById(i), r=d.getElementById(p+"-root"),
                u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
                        :"static."+p+".com";
        if (e) return;
        e = d.createElement(s); e.id = i; e.async = true;
        e.src = h+"//"+u+"/p.js"; r.appendChild(e);
    })("script", "parsely", document);
</script>
<!-- END Parse.ly Include -->

    <script type="text/javascript">
        (function(window){
    
            window.visitor = Visitor.getInstance('A65F776A5245B01B0A490D44@AdobeOrg', {
                trackingServer       : 'an.milb.com',
                trackingServerSecure : 'ans.milb.com'
            });
    
            var siteID = (MiLB_ARTICLES.siteID === 'milb' ? '000' : MiLB_ARTICLES.siteID.slice(1));
            var reportingSuiteIds         = 'milbglobal,milb';
            reportingSuiteIds += siteID;
    
            var s = window.adobeAnalytics = s_gi(reportingSuiteIds);
    
            s.visitor                 = Visitor.getInstance('A65F776A5245B01B0A490D44@AdobeOrg');
            s.trackingServer          = 'an.milb.com';
            s.trackingServerSecure    = 'ans.milb.com';
            s.linkInternalFilters     = "javascript:,mlb.com,localhost,minorleaguebaseball,milb";
            s.charSet                 = "ISO-8859-1";
            s.currencyCode            = "USD";
            s.trackDownloadLinks      = true;
            s.trackExternalLinks      = true;
            s.trackInlineStats        = true;
            s.linkDownloadFileTypes   = "exe,zip,wav,mp3,mov,mpg,avi,wmv,pdf,doc,docx,xls,xlsx,ppt,pptx,csv,m4v";
            s.linkLeaveQueryString    = false;
            s.linkTrackVars           = "";
            s.linkTrackEvents         = "";
    
            window.trackPageView = function( dataObj ) {
                var keys = Object.keys(dataObj);
                var len = keys.length;
                s.clearVars();
    
                if (len > 0) {
                    keys.map(function(key) {
                        s[key] = dataObj[key];
                    });
                }
    
                s.t();
            };
    
            window.trackAsync = function(omJson, callingObj) {
                var s = s_gi( reportingSuiteIds );
                s.clearVars();
    
                if(omJson.async) {
                    var props = omJson.async;
    
                    var prop;
                    for ( prop in props ) {
                        s[ prop ] = props[ prop ];
                    }
    
                    if (omJson.callback) {
                        omJson.callback();
                    }
                }
    
                var arbitraryObject = new Object();
                arbitraryObject.href="http://myGenericURL";
                if (!callingObj) {
                    callingObj = arbitraryObject;
                }
    
                if (s.prop14) {
                    s.tl(callingObj,'o',s.prop14);
                } else if (s.prop1) {
                    s.tl(callingObj,'o',s.prop1);
                } else if (s.prop38) {
                    s.tl(callingObj,'o',s.prop38);
                } else if (s.prop44) {
                    s.tl(callingObj,'o',s.prop44);
                } else if (s.prop45) {
                    s.tl(callingObj,'o',s.prop45);
                } else if (s.prop12) {
                    s.tl(callingObj,'o',s.prop12);
                } else if (s.prop14) {
                    s.tl(callingObj,'o',s.prop14);
                } else if (s.prop27) {
                    s.tl(callingObj,'o',s.prop27);
                } else if (s.eVar23) {
                    s.tl(callingObj,'o',s.eVar23);
                } else if (s.eVar27) {
                    s.tl(callingObj,'o',s.eVar27);
                } else if (s.eVar28) {
                    s.tl(callingObj,'o',s.eVar28);
                } else {
                    s.tl(callingObj,'o',s.events);
                }
            };
    
        })(window);
    </script>


<!-- footer -->
<footer class="footer site-footer milb primary-bg">
    <ul class="legal">
        <li><a target="_blank" href="/r/links/terms-of-use">Terms of Use</a></li>
        <li>|</li>
        <li><a target="_blank" href="/r/links/privacy-policy">Privacy Policy</a></li>
        <li>|</li>
        <li><a href="javascript:void(window.open('http://www.milb.com/milb/info/privacy.jsp#about_our_ads','PopupWindow','width=900,height=280,location=no,menubar=no,scrollbars=yes,status=no,toolbar=no,resizable=yes'));">About Our Ads</a></li>
    </ul>
    <p class="copyright">Copyright &copy; <script type="text/javascript">document.write(new Date().getFullYear());</script> Minor League Baseball. <span class="ext">Minor League Baseball trademarks and copyrights are the property of Minor League Baseball.</span> All Rights Reserved.</p>
    <ul class="poweredby">
        <li><i>Powered by</i></li>
        <li>
            <a href="http://mlb.mlb.com/home">
                <img src="//secure.mlb.com/images/8/5/8/113325858/mlb.com_85zr0j8l.png">
            </a>
        </li>
        <li>
            <select onchange="window.parent.location.href='http://'+this.options[this.selectedIndex].value+'.com'">
                <option value="">MLB Clubs</option>
                <option value="mlb">MLB.com</option>
                <option value="angels.mlb">Angels</option>
                <option value="astros.mlb">Astros</option>
                <option value="athletics.mlb">Athletics</option>
                <option value="bluejays.mlb">Blue Jays</option>
                <option value="braves.mlb">Braves</option>
                <option value="brewers.mlb">Brewers</option>
                <option value="cardinals.mlb">Cardinals</option>
                <option value="cubs.mlb">Cubs</option>
                <option value="diamondbacks.mlb">Diamondbacks</option>
                <option value="dodgers.mlb">Dodgers</option>
                <option value="giants.mlb">Giants</option>
                <option value="indians.mlb">Indians</option>
                <option value="mariners.mlb">Mariners</option>
                <option value="marlins.mlb">Marlins</option>
                <option value="mets.mlb">Mets</option>
                <option value="nationals.mlb">Nationals</option>
                <option value="orioles.mlb">Orioles</option>
                <option value="padres.mlb">Padres</option>
                <option value="phillies.mlb">Phillies</option>
                <option value="pirates.mlb">Pirates</option>
                <option value="rangers.mlb">Rangers</option>
                <option value="rays.mlb">Rays</option>
                <option value="redsox.mlb">Red Sox</option>
                <option value="reds.mlb">Reds</option>
                <option value="rockies.mlb">Rockies</option>
                <option value="royals.mlb">Royals</option>
                <option value="tigers.mlb">Tigers</option>
                <option value="twins.mlb">Twins</option>
                <option value="whitesox.mlb">White Sox</option>
                <option value="yankees.mlb">Yankees</option>
            </select>
        </li>
    </ul>
</footer>


    <!-- core javascript files -->
    <script>var s_account = '';</script>
    
    
        <script type="text/javascript" src="//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/scripts/site-core.js"></script>
    

    <!-- build scripts -->
    <script type="text/javascript">
    
        (function() {
    
            var siteJS = {"desktop":"site","tablet":"site","phone":"site"};
            var sectionJS = {"desktop":"","tablet":"","phone":""};
            var pageJS = {"desktop":"index","tablet":"index-device","phone":"index-device"};
            var type = getStartupDeviceTypeString();
    
    
            /* site and section build=true */
    
                var siteScripts = [];
                var scripts = [];
    
                if (siteJS[type]) {
                    siteScripts.push('//prod-aws.milbstatic.com/builds/site-core/79e54ac0d04effb4663ed8ba43745fc072397d4b_1516834201/scripts/'+siteJS[type]+'.js');
                }
    
                if (sectionJS[type]) {
                    scripts.push('//prod-aws.milbstatic.com/sections/news/builds/3d4d9cc891e900f0e30bf386ef746ad79ba60272_1513702082/scripts/'+sectionJS[type]+'.js');
                }
                if (pageJS[type]) {
                    scripts.push('//prod-aws.milbstatic.com/sections/news/builds/3d4d9cc891e900f0e30bf386ef746ad79ba60272_1513702082/scripts/'+pageJS[type]+'.js');
                }
                if (siteScripts.length) {
                    requirejs.config({
                        waitSeconds: 18,
                        paths : {
                            "bam-video-bootstrap": "//prod-aws.milbstatic.com/video/videocore/video"
                        }
                    });
    
                    requirejs(siteScripts, function(){
                        if (scripts.length) {
                            requirejs(scripts);
                        }
                    });
                }
    
    
        })();
    </script>

    <!-- analytics -->
    <script type="text/javascript">
        (function(window){
    
            window.visitor = Visitor.getInstance('A65F776A5245B01B0A490D44@AdobeOrg', {
                trackingServer       : 'an.milb.com',
                trackingServerSecure : 'ans.milb.com'
            });
    
            var siteID = (MiLB_ARTICLES.siteID === 'milb' ? '000' : MiLB_ARTICLES.siteID.slice(1));
            var reportingSuiteIds         = 'milbglobal,milb';
            reportingSuiteIds += siteID;
    
            var s = window.adobeAnalytics = s_gi(reportingSuiteIds);
    
            s.visitor                 = Visitor.getInstance('A65F776A5245B01B0A490D44@AdobeOrg');
            s.trackingServer          = 'an.milb.com';
            s.trackingServerSecure    = 'ans.milb.com';
            s.linkInternalFilters     = "javascript:,mlb.com,localhost,minorleaguebaseball,milb";
            s.charSet                 = "ISO-8859-1";
            s.currencyCode            = "USD";
            s.trackDownloadLinks      = true;
            s.trackExternalLinks      = true;
            s.trackInlineStats        = true;
            s.linkDownloadFileTypes   = "exe,zip,wav,mp3,mov,mpg,avi,wmv,pdf,doc,docx,xls,xlsx,ppt,pptx,csv,m4v";
            s.linkLeaveQueryString    = false;
            s.linkTrackVars           = "";
            s.linkTrackEvents         = "";
    
            window.trackPageView = function( dataObj ) {
                var keys = Object.keys(dataObj);
                var len = keys.length;
                s.clearVars();
    
                if (len > 0) {
                    keys.map(function(key) {
                        s[key] = dataObj[key];
                    });
                }
    
                s.t();
            };
    
            window.trackAsync = function(omJson, callingObj) {
                var s = s_gi( reportingSuiteIds );
                s.clearVars();
    
                if(omJson.async) {
                    var props = omJson.async;
    
                    var prop;
                    for ( prop in props ) {
                        s[ prop ] = props[ prop ];
                    }
    
                    if (omJson.callback) {
                        omJson.callback();
                    }
                }
    
                var arbitraryObject = new Object();
                arbitraryObject.href="http://myGenericURL";
                if (!callingObj) {
                    callingObj = arbitraryObject;
                }
    
                if (s.prop14) {
                    s.tl(callingObj,'o',s.prop14);
                } else if (s.prop1) {
                    s.tl(callingObj,'o',s.prop1);
                } else if (s.prop38) {
                    s.tl(callingObj,'o',s.prop38);
                } else if (s.prop44) {
                    s.tl(callingObj,'o',s.prop44);
                } else if (s.prop45) {
                    s.tl(callingObj,'o',s.prop45);
                } else if (s.prop12) {
                    s.tl(callingObj,'o',s.prop12);
                } else if (s.prop14) {
                    s.tl(callingObj,'o',s.prop14);
                } else if (s.prop27) {
                    s.tl(callingObj,'o',s.prop27);
                } else if (s.eVar23) {
                    s.tl(callingObj,'o',s.eVar23);
                } else if (s.eVar27) {
                    s.tl(callingObj,'o',s.eVar27);
                } else if (s.eVar28) {
                    s.tl(callingObj,'o',s.eVar28);
                } else {
                    s.tl(callingObj,'o',s.events);
                }
            };
    
        })(window);
    </script>


</body>
</html>
